Centos7 安装Docker

Docker从1.13版本之后采用时间线的方式作为版本号,分为社区版CE和企业版EE。

社区版是免费提供给个人开发者和小型团体使用的,企业版会提供额外的收费服务,比如经过官方测试认证过的基础设施、容器、插件等。

社区版按照stable和edge两种方式发布,每个季度更新stable版本,如17.06,17.09;每个月份更新edge版本,如17.09,17.10。

前期准备,可以装个Centos7的虚拟机,参考这里:http://www.yihaomen.com/article/Architect/701.htm

然后针对虚拟机更改 yum, 可以参考这里:http://www.yihaomen.com/article/Architect/702.htm

一、安装docker

1、Docker 要求 CentOS 系统的内核版本高于 3.10 ,查看本页面的前提条件来验证你的CentOS 版本是否支持 Docker 。

通过 uname -r 命令查看你当前的内核版本

uname -r
    

2、使用 root 权限登录 Centos。确保 yum 包更新到最新。这一步需要小心,如果是生产环境一定要注意。甚至可以忽略过.

sudo yum update
    

3、卸载旧版本(如果安装过旧版本的话)

sudo yum remove docker  docker-common docker-selinux docker-engine
    

4、安装需要的软件包, yum-util 提供yum-config-manager功能,另外两个是devicemapper驱动依赖的

sudo yum install -y yum-utils device-mapper-persistent-data lvm2
    

5、设置yum源

sudo yum-config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo

上面这个在安装docker的时候可能报错,因为网络问题,是老问的站,另外因为国内的GFW的问题,如果不行的话可以换阿里的:

yum-config-manager --add-repo http://mirrors.aliyun.com/docker-ce/linux/centos/docker-ce.repo

6、可以查看所有仓库中所有docker版本,并选择特定版本安装

yum list docker-ce --showduplicates | sort -r
    

如果这里出现 https://download.docker.com/linux/centos/docker/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found这样的错误,那么就用上面阿里的doce-ce.repo, 同时删掉原来老外的哪个,进入/etc/yum.repos.d这个目录去删除.

7、安装docker

sudo yum install docker-ce  #由于repo中默认只开启stable仓库,故这里安装的是最新稳定版17.12.0$ sudo yum install <FQPN>  # 例如:sudo yum install docker-ce-17.12.0.ce
    

8、启动并加入开机启动

sudo systemctl start docker
sudo systemctl enable docker
9、验证安装是否成功(有client和service两部分表示docker安装启动都成功了)
docker version
    

 

二、问题

1、因为之前已经安装过旧版本的docker,在安装的时候报错如下:

 Transaction check error:  file /usr/bin/docker from install of docker-ce-17.12.0.ce-1.el7.centos.x86_64 conflicts with file from package docker-common-2:1.12.6-68.gitec8512b.el7.centos.x86_64  file /usr/bin/docker-containerd from install of docker-ce-17.12.0.ce-1.el7.centos.x86_64 conflicts with file from package docker-common-2:1.12.6-68.gitec8512b.el7.centos.x86_64  file /usr/bin/docker-containerd-shim from install of docker-ce-17.12.0.ce-1.el7.centos.x86_64 conflicts with file from package docker-common-2:1.12.6-68.gitec8512b.el7.centos.x86_64  file /usr/bin/dockerd from install of docker-ce-17.12.0.ce-1.el7.centos.x86_64 conflicts with file from package docker-common-2:1.12.6-68.gitec8512b.el7.centos.x86_64
    

2、卸载旧版本的包

 sudo yum erase docker-common-2:1.12.6-68.gitec8512b.el7.centos.x86_64
    

3、再次安装docker

sudo yum install docker-ce
    


除非申明,文章均为一号门原创,转载请注明本文地址,谢谢!
[本日志由 yihaomen 于 2019-06-01 11:07 PM 编辑]
文章来自: 本站原创
引用通告: 查看所有引用 | 我要引用此文章
Tags:
相关日志:
评论: 0 | 引用: 0 | 查看次数: -
发表评论
昵 称:
密 码: 游客发言不需要密码.
内 容:
验证码: 验证码
选 项:
虽然发表评论不用注册,但是为了保护您的发言权,建议您注册帐号.